2018年3月8日 星期四

Win10下如何選用TensorFlow的版本?

最近,TensorFlow的版本大幅度的更新,主要是更新支援AVX指令集與CUDA9.0/cuDNN 7.0。
版本眾多混亂,那該怎麼選擇適合、可運行的TenorFlow 版本呢?

會需要使用到CPU- Z,請先下載。
CPU- Z:https://www.cpuid.com/softwares/cpu-z.html

開啟CPU-Z,點選Graphics查看顯示卡是否為nVIDIA。

如果為否,則安裝CPU版。反之,則可以安裝GPU版加速。

接著點開CPU的部份,查看是否有AVX的指令集。



如果為否,安裝1.6.0版會出bug,需要安裝1.5.0(含以前)的版本。如果有支援AVX則可安心使用1.6.0版。

綜合以上所述:



是否為Nvidia之顯卡
CPU是否支援AVX指令集
GPU 1.6.0
CPU 1.6.0
GPU 1.5.0
(含以下)
CPU 1.6.0


各版本在Python 3.6版64bit之安裝指令:
GPU 1.6.0 :
pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-1.6.0-cp36-cp36m-win_amd64.whl
 GPU 1.5.0:
pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-1.5.0-cp36-cp36m-win_amd64.whl
 CPU 1.6.0:
pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.6.0-cp36-cp36m-win_amd64.whl
 CPU 1.5.0:
pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.5.0-cp36-cp36m-win_amd64.whl

相關安裝請參考:於Win10下安裝TensorFlow並用GPU做加速




創用 CC 授權條款
本著作由Wei製作,以創用CC 姓名標示-非商業性 4.0 國際 授權條款釋出。

沒有留言:

張貼留言